#1 2017-05-15 18:32:53

bernd
New member
Registered: 2017-05-15
Posts: 6

ofdb.de plugin not working

I just installed gcstar 1.7.1 on arch via AUR. But the ofdb.de plugin always throws out "element not found" (while imdb is working).

Can anyone give me a hint to get the plugin working?

Thanks smile

Offline

 

#2 2017-05-16 15:19:58

kerenoc
Member
Registered: 2016-03-19
Posts: 92

Re: ofdb.de plugin not working

Some web sites are migrating to TLS/HTTPS and some other GCstar plugins stopped working because of that.

Tian has recently made some changes in the official GCstar repository http://svn.gna.org/viewcvs/gcstar/ that could fix the problem.

I did tsimilar evolutions on my Gitlab repository where I try to follow the latest version of the plugins. Using that, I got results from OFdb (no picture though).

In both case, if you download an archive of the source files, you should copy the lib/gcstar directory where GCstar was installed (most probably /usr/lib/gcstar).

Hope this helps.

Offline

 

#3 2017-05-17 13:33:02

bernd
New member
Registered: 2017-05-15
Posts: 6

Re: ofdb.de plugin not working

Hi kerenoc, thanks for you reply!

I will check out the repositories and report back. Maybe this also helps other users.

Offline

 

#4 2017-05-20 16:09:47

bernd
New member
Registered: 2017-05-15
Posts: 6

Re: ofdb.de plugin not working

1. used /lib from http://svn.gna.org/viewcvs/gcstar/: gstar wouldn't start at all

2. used /lib from https://gitlab.com/Kerenoc/GCstar/tree/Test: no difference, could not find element

any suggestions?

Offline

 

#5 2017-05-23 10:32:06

kerenoc
Member
Registered: 2016-03-19
Posts: 92

Re: ofdb.de plugin not working

Hello

I checked the Test version from GitLab on an Ubuntu distribution. OFDb is able to get some information from the site including covers and synopsis after the changes I made to the plugin.

Maybe extract the version in a clean directory, go to "gcstar/bin" and try to launch "perl gcstar".

Offline

 

#6 2017-06-01 13:38:38

bernd
New member
Registered: 2017-05-15
Posts: 6

Re: ofdb.de plugin not working

Did a clean install manually from gitlab/test, now ofdb works! Thank you! smile smile

Offline

 



Should you have a problem using GCstar, you can open a bug report or request some support on GCstar forums.