#1 2017-08-13 04:46:15

crmccluskey
Member
Registered: 2017-05-21
Posts: 13

Sort Order Issues

I have a list of Films. Despite playing with various sort options, I can't seem to get a simple sort to work (in either the Text List or Detailed List Views). I'm cool with number literal or ASCII sort orders, but right now I'm not understanding the current sort order.

Attached is a pic with the current sort order (masked since the list isn't suitable for public consumption). Despite clearing "Group By" and clicking on the Title Column (sending order), the sorting doesn't appear to work.

Any ideas on what I'm missing or how to continue to debug?

Thank you,
Chris

PS. I'm using the GitLab version of the code, here: https://gitlab.com/Kerenoc/GCstar/tree/Test

Offline

 

#2 2017-08-13 07:57:13

kerenoc
Member
Registered: 2016-03-19
Posts: 92

Re: Sort Order Issues

I can reproduce this bug in my configuration. Maybe it's related to the configuration of the language by the OS (Locale, LANG, LC_ALL, etc...).

Offline

 

#3 2017-08-13 17:04:38

crmccluskey
Member
Registered: 2017-05-21
Posts: 13

Re: Sort Order Issues

Thank you Kerenoc,

While its not 100% yet* changing the environment from:

LANG="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_ALL=

to:
LANG=
LC_COLLATE="C"
LC_CTYPE="C"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL=

did help. I'll need to play with this a little more and see if it effects importation, and see what other possibilities there are.

* I have a UPC titled item, 7xx41914xxxxx, in the W's, but the rest of the looks sorted correctly.


Thank you.

Offline

 



Should you have a problem using GCstar, you can open a bug report or request some support on GCstar forums.