#1 2010-04-23 09:16:26

Halibutt
Member
From: Warsaw
Registered: 2007-05-12
Posts: 19
Website

Polish book plugins broken (wrong encoding)

GCStar 1.50, Windows (both XP Home and Vista Business checked)

The three Polish book searches have a huge problem with Polish diacritics. In Merlin and Mareno the title search works just fine (although in Mareno barely any field gets filled, no cover picture for instance) - unless the title includes a Polish diacrite (ś, ć, ź, ń and such). In that case the search is completely broken.

Let's take this book for instance: "Życie erotyczne Anais Nin". Merlin finds it fine,so does Mareno. Yet when I try to find that book from within GCStar, the search fails. No titles starting with a Polish diacrite return any searches.

What's more, even the books that are being found have fancy characters instead of Polish diacrites. ( instead of ć, instead of ą, instead of ę, instead of ś and so on). It looks as if GCStar was predefined to use Latin-1 encoding even though the plugins use different encodings.

Is there a way to fix the encoding used by GCStar for the database?
Cheers


Why oh why is writing plugins for GCStar so complicated...

Offline

 

#2 2010-04-27 11:50:24

Halibutt
Member
From: Warsaw
Registered: 2007-05-12
Posts: 19
Website

Re: Polish book plugins broken (wrong encoding)

There is the following part of code inside of Merlin plugin, it seems not to be loaded correctly:

Code:

    sub getCharset
    {
        my $self = shift;
        #return "UTF-8";
        return "ISO-8859-2";
    }

Anybody knows how to make GCStar use it correctly?
Cheers

BTW, filed a new bug report here: https://bugs.launchpad.net/gcstar/+bug/570661

Last edited by Halibutt (2010-04-27 11:56:31)


Why oh why is writing plugins for GCStar so complicated...

Offline

 



Should you have a problem using GCstar, you can open a bug report or request some support on GCstar forums.