• Index
  •  » Bug reports
  •  » GCStar doesn't recognize files in East Asian languages.

#1 2021-04-29 14:07:33

DreamingPrince
New member
Registered: 2021-04-28
Posts: 2

GCStar doesn't recognize files in East Asian languages.

I'm unsure if this counts as a bug report or a feature request, seeing as I'm sure the culprit is character encoding, but I'll put it here. Please move it if it's better as a request.

I was happy to discover this program so that I could use it to sort my various collections of East Asian media items, but I found that the program doesn't recognize files if they have Japanese, Korean, or Chinese characters in the filename. This is a pretty big detriment to my cataloguing seeing as I'm currently cataloging my collections by saving the image of the cover with the name of the item, which is usually in Japanese, Chinese, or Korean.

I attached a screencap of what happens when you try to use an image or a file with these characters; I'm trying to load an image. Pressing 'okay' when selected like this will just bring you back to the item screen without loading your image.


Attachments:
Attachment Icon nogo.png, Size: 54,465 bytes, Downloads: 28

Offline

 

#2 2021-04-30 07:59:19

kerenoc
Administrator
Registered: 2016-03-19
Posts: 408
Website

Re: GCStar doesn't recognize files in East Asian languages.

There are some differences between the Gtk2 and Gtk3 version with regard to the support of character set. Which version of GCstar are you using and what are your operating system settings for the localisation and languages?

Offline

 

#3 2021-05-01 13:17:40

DreamingPrince
New member
Registered: 2021-04-28
Posts: 2

Re: GCStar doesn't recognize files in East Asian languages.

I'm on Windows 10. Using the 1.7.3 version of Gtk3 for Windows. My system is set to English with all the proper East Asian character packs installed.

Offline

 

#4 2021-06-02 15:47:32

kerenoc
Administrator
Registered: 2016-03-19
Posts: 408
Website

Re: GCStar doesn't recognize files in East Asian languages.

Sorry for the delay but may was quite busy!

In GTK3 there is an environment variable G_FILENAME_ENCODING (see https://developer.gnome.org/gtk3/stable … ooser.html ). Maybe you could try to set it to your local localisation parameters.

Offline

 
  • Index
  •  » Bug reports
  •  » GCStar doesn't recognize files in East Asian languages.



Should you have a problem using GCstar, you can open a bug report or request some support on GCstar forums.