#1 2011-02-19 02:52:40

udx6bs
New member
Registered: 2008-09-08
Posts: 2

Special Characters in path

Version: 1.6.1Operating system: MSWin32Error message: G:\Alkalmazások\3D\catalogue.gcsCannot open items list. Please check access rights.Additional information:

When I tried to save my catalogoue under
"G:\Alkalmazások\3D\catalogue.gcs", it saved it under
"G:\Alkalmazások\3D\".

Looks like some sort of encoding bug.

Saving special characters in my fields to the .gcc file is OK:

<item
  gcsfield1="New item"
  gcsfield2="bla"
  gcsfield3="bla"
  gcsfield5="bla"
  gcsfield6="bla"
  gcsfield7="bla"
  gcsfield8="G:\Alkalmazások\3D\bla.7z"
  gcsfield9="bla/bla.jpg"
  gcsautoid="1"
>



gcsfield 8 is type file. If I click on Open it shows:

File to launch was not found in this location:

G:\Alkalmazások\3D\bla.7z

however the file does exist, I think it tries to open
G:\Alkalmazások\3D\bla.7z


The same goes to field9 which is an Image (The image doesn't show in the program)


I see that in 2007 someone posted a bugreport on this (http://forums.gcstar.org/viewtopic.php?id=180), and the answer was we shouldnt use special characters in paths. Is it possible that you take that now in consideration to fix or is it still a problem needed lot of coding?

OS: Win7 Ultimate 64bit.

Thx in advance
Cheers

Offline

 

#2 2011-04-12 01:24:50

Halibutt
Member
From: Warsaw
Registered: 2007-05-12
Posts: 19
Website

Re: Special Characters in path

It's possibly related to other similar bugs in GC, for instance the one that prevents Polish book sites from being properly scraped by GC Star (check this report for instance: http://forums.gcstar.org/viewtopic.php?id=1786, but there were many, many more problems with non-standard latin characters filed).
Cheers


Why oh why is writing plugins for GCStar so complicated...

Offline

 



Should you have a problem using GCstar, you can open a bug report or request some support on GCstar forums.